Question

I know there is a plenty on the Internet, but I am afraid to touch it since the data on my partition is valuable for me now.

My situation:

I have MacBook Air with OS Yosemite 2011 11" (128G).

I wanted to create a dual-boot configuration (MacOS + Windows) and succeeded. (I did following protective MBR creation manual somewhere on the net). After a while, Windows started consuming too much space, so I decided to re-install it with a lighter build.

What happened is that I dropped the partition (600 MB) in Windows installer in order to re-map the space, and LOST ability to boot in MacOS.

( Originally, I thought it was Microsoft Reserved partition, but the answer below suggested it was "booter" partition. )

I did restore the boot by installing rEFInd to EFI drive.

Currently, MacOS partition is not visible if I press "Options" key, but it still boots up thankfully to EFI boot.

Trying to remap the drive, I did drop all Windows partitions in order to put that space back to MacOS one.

The issue is that now I can not edit partitions via DiskUtility (the one with GUI) - it just simply does nothing when I try to modify them. It shows gray circle at the beginning of "MBR" space.

My output of diskutil list is following (there is an interesting thing that record for GPT and MBR for MacOS partition is different: 51.2GB versus 50.8GB, that has happened because I did merge dropped 600MB with MacOS partition via DiskUtility):

mes-MacBook-Air:~ me$ sudo diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:          Apple_CoreStorage                         51.2 GB    disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS MacOS                  *50.8 GB    disk1
                                 Logical Volume on disk0s2
                                 84A33FDC-BA63-43B5-A43F-E4BF61D0830A
                                 Unencrypted

$ sudo gpt -r show /dev/disk0 
    start         size  index  contents 
        0            1         PMBR 
        1            1         Pri GPT header 
        2            4         Pri GPT table 
        6        76800      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B 
    76806     12500474      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC 
 12577280     17044987 
 29622267            4         Sec GPT table 
 29622271            1         Sec GPT header 

Help me out to put the space back and merge it back into one. Or guide me to the good source on the topic if I ask too much.

Thank you people.

Was it helpful?

Solution 2

I fixed my problem using these steps:

  1. diskutil cs revert 84A33FDC-BA63-43B5-A43F-E4BF61D0830A
  2. Rebooted to ensure that Yosemite boot option is back.
  3. Opened DiskUtility (with GUI), created second "MacOS2" partition from empty space.
  4. Dropped "MacOS2" partition.
  5. After that, I was able to drag the first "MacOS" partition and use all the space for it.

Current output of:

sudo diskutil list

mes-MacBook-Air:~ me$ sudo diskutil list
Password:
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                  Apple_HFS MacOS                   120.9 GB   disk0s2

sudo gpt -r show /dev/disk0

mes-MacBook-Air:~ me$ sudo gpt -r show /dev/disk0
     start      size  index  contents
         0         1         PMBR
         1         1         Pri GPT header
         2         4         Pri GPT table
         6     76800      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     76806  29512693      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  29589499     32768         
  29622267         4         Sec GPT table
  29622271         1         Sec GPT header

sudo diskutil cs list

mes-MacBook-Air:~ me$ sudo diskutil cs list
No CoreStorage logical volume groups found

Thank you everyone who helped me out and just read.

God bless you mankind : )

OTHER TIPS

You deleted too many partitions. You deleted the booter partition used to boot Yosemite.

Normally, the command given below would be used to reclaim the missing space.

diskutil cs resizestack 84A33FDC-BA63-43B5-A43F-E4BF61D0830A 0

However, if you issue this command, I would assume you would get an error message similar to what is shown below. The error is due to the missing booter partition and is not due to the target partition being too small.

Error: -69722: You can't perform this resize unless it has a booter (target partition is probably too small)

I am not sure if you can revert the Core Storage volume. You would have had to include the output from the command disktuil cs list in order for me to determine this.

You could try entering the command given below. This attempts to change the Yosemite volume to "Mac OS Extended (Journaled)". If successfully, you should be able to view Yosemite in the Startup Manager.

diskutil cs revert 84A33FDC-BA63-43B5-A43F-E4BF61D0830A 

If unsuccessful, you will probably need to reinstall Yosemite. If successful, you can post a new question asking how to proceed.

Licensed under: CC-BY-SA with attribution
Not affiliated with apple.stackexchange
scroll top