Question

Possible Duplicate:
Naming Boolean columns in Rails

What is the rails convention regarding names of boolean fields?

For example, if I have a User model that needs a flag for its "activeness", should I call the db field is_active or active ?

Note: Rails automatically generates question-marked methods for accessing boolean fields: User.is_active? and User.active?.

Was it helpful?

Solution

The plain-adjective form is easily the norm in Ruby and Rails — even?, nil?, empty? and blank? for example. The only method of the form is_#{something}? that I can think of is Kernel#is_a? to determine class identity. So to stick with standard naming conventions, I would leave off the is_ on boolean methods like this.

OTHER TIPS

Of the 2 you should choose the one that sounds better to you: User.active? or User.is_active?

I'd personally opt for the former.

The question mark goody comes from Ruby, not Rails.

Licensed under: CC-BY-SA with attribution
Not affiliated with StackOverflow
scroll top