문제

I have a class which will contain list of two dependent classes inside it.

example

Class ActivityHolder{
    private ArrayList activityList;
    private ArrayList promiseList;
}

My question is how do i name the ActivityHolder class. [Edit]

I have a class structure as above.And not the wallet and coin scenario.

도움이 되었습니까?

해결책

Like Richard and amal pointed, the class name must be something related to its function. If it represents a bunch of activities, so it is okay to name it Activities.

Class Activities {
    private List activities;  // backlog, planned, other better name (more specific) 
    private List promises;
}
라이센스 : CC-BY-SA ~와 함께 속성
제휴하지 않습니다 StackOverflow
scroll top