Вопрос

I have a class which will contain list of two dependent classes inside it.

example

Class ActivityHolder{
    private ArrayList activityList;
    private ArrayList promiseList;
}

My question is how do i name the ActivityHolder class. [Edit]

I have a class structure as above.And not the wallet and coin scenario.

Это было полезно?

Решение

Like Richard and amal pointed, the class name must be something related to its function. If it represents a bunch of activities, so it is okay to name it Activities.

Class Activities {
    private List activities;  // backlog, planned, other better name (more specific) 
    private List promises;
}
Лицензировано под: CC-BY-SA с атрибуция
Не связан с StackOverflow
scroll top